2014年11月21日金曜日

Eclipse 4.4 (Luna)を利用する際はJDK/JREは1.7以上に

ラボのPCでGWTの環境を再構築したものの、GWTが使えないという事象が発生。Google Plugin for Eclipseのインストールには成功しているのだが、そのplug-inが有効にならない。ファイルの新規プロジェクトメニューにGoogleのカテゴリーが出てこないという、、、で、原因は
  • LunaはJDK1.7以上が要求仕様であり、PCのJDKが1.6のままであったため

ということ。正確に言えば、Lunaは正常に?起動するが、多くのplug-inが1.7ベースになっているというので、まともに動かないということのようだ。。。
Javaのバージョンは下記のように確認できる。






なお、現在のJDKは 1.8が最新版だが、GAE/Jは1.7を前提にしているので注意が必要だろう。


0 件のコメント:

コメントを投稿