2016年4月15日金曜日

Unity:Scene 'XXXXX' (-1) couldn't be loaded because it has not been added to the build

Unityにて画面(シーン)の遷移をするときに
Unity:Scene 'XXXXX' (-1) couldn't be loaded because it has not been added to the build 
というエラーメッセージが出ることがあります。 これは、遷移先のシーンが登録されていないという意味です。File→Build Settings にて、シーンを登録しましょう(ドラッグ&ドロップ)。

2016年4月8日金曜日

GWTBootstrap3にてModalウィンドウを使う

GWTBootstrap3にてボタンクリックでModalウィンドウを呼び出す方法です。いちおう方法としては、
  • ボタンのクリックイベントを検知して表示
  • UiBinderのタグにて定義しておく
の2種類の方法があります。個人的には前者の方法が無難かと思いますが、表示するだけならタグだけでもできるようです。

下記にサンプルを書いてますが、まずModalウィンドウについては、新たにxmlファイルを用意する必要はなく、呼び出し元となる画面内で定義しておいてもOK(表示されない)なようです。で、クリックされた時に、Modal::show()とするか、下記の例のようにタグで定義できます。ポイントは、
  • b:id属性でModalの名前定義
  • ボタン側でdataTarget属性で、呼び出すModalのidを記述
という感じでできるようです。


2016年4月5日火曜日

Apacheが急に起動しなくなった際 にやったことメモ

server

先日、ウェブサーバーがダウンしたので、復旧させた時のメモ書きです。プロセスをみるとhttpdが動いてない。また管理ツールのサービスで起動しても、起動に失敗する。設定を特に変えた記憶なし。突然のサーバー停止です。

サーバー名に齟齬が発生?
こういうときは、コマンドラインで起動させたほうがいいので起動させると以下のようなエラーが。。。
/etc/in it.d/httpd start
httpd: Could not reliably determine the server’s fully qualified domain name, using local domain.localhost for ServerName

/etc/sysconfig/networkと/etc/hostsに書かれてあるサーバー名と/etc/httpd/conf/httpd.confに書かれてあるサーバー名にズレがあることによるらしい。よって、
ServerName www.ochi-lab.org:80
みたいに記述を追記しておくと良い感じ。

Server-Cert証明書の問題
実は、上記の設定でエラーメッセージは出なくなりましたが、相変わらず起動しない。他に原因がある?ということで、
/etc/httpd/log
を調べてみると、
Unable to verify certificate 'Server-Cert'. Add "NSSEnforceValidCerts off" to nss.conf so the server can start until the problem can be resolved.
というエラーメッセージを発見。
Server-Cert証明書の有効期限が切れているので起動に失敗するようだ。で、解決策としてはこのメッセージに書かれているように、etc/httpd/conf.d/nss.conf ファイルにおいて、NSSEnforceValidCerts off という記述をすればOK。以上で、無事起動です。

今回の事象ははググればたくさん出てきますが、検索キーをどうするかが大切です。そのために原因となるエラーメッセージを見つけ出すのが肝ですね。



「Java was started but returned exit code=13」というエラーでEclipseが起動しない場合の対処法

PCのデフォルトのJVMとEclipseのバージョンが違うだけですので、揃えましょう。方法としては次のいずれかで。。。

【方法1】
  • JREを入れなおす
【方法2】
  • eclipse.iniに下記を追加

    -vm
    C:\java\jdk1.8\bin\javaw.exe

    #最初の行に。上記のように改行して2行で構成させてOK。


2016年4月1日金曜日

SeaPort.exeなる怪しいサービスを停止した

ラボ内のあるPCを起動すると、LANのハブのランプがチカチカと忙しく点滅する。。。なんだこれは?(ウィルスか?)ということで、調べてみる。こういう時に一番いい方法は
  • リソースモニター(タスクマネージャー→パフォーマンスの下から起動)
これを使うと、どのプロセスが通信しているのかがわかる(正常なソフトであれば)。。。で、確認すると、表題のプロセスが。。。で、ググると、
  • Windows Live検索ツール「Search Enhancement Pack」のプログラム
ということらしいので、迷わずサービスを無効。静かになりました。