2011年5月23日月曜日

GWT 移行時のバージョン違いで出るエラー

GWTは発展途上のライブラリーですから、バージョンは上がってきます。開発時に利用していたバージョンと最新バージョンにズレが発生することが多々あり、その際、最新バージョンに変えようというデキ心がよく起こったりします。それがいいかどうかは状況にもよりますが、移行時にきちんとバージョンを合わせないとエラーができます。下記のようなエラーは、バージョン違いの時のエラーです。
Loading modules
   com.eric.gwttest.gwt.ApplicationCommon
      Loading inherited module 'com.google.gwt.app.App'
         Loading inherited module 'com.google.gwt.user.User'
            Loading inherited module 'com.google.gwt.core.Core'
               Loading inherited module 'com.google.gwt.core.XSLinker'
                  [ERROR] Line 22: Unexpected element 'when-linker-added'
                  [ERROR] Failure while parsing XML

Netbeansの場合、使用しているライブラリーで古いバージョンのが混在することがあります。よくこのことをすっかり忘れていて、意味不明のエラーだと思って迷わないようにしましょう。

0 件のコメント:

コメントを投稿